You are browsing the latest version of the documentation which is not released yet. See the current stable version instead.

Application Requirements

To be able to install, develop and run Shopsys Framework, the system should have preinstalled some tools and services.

Linux / MacOS / WSL

Windows

Info

The names link to the appropriate installation guide or download page.

Note

optional Nginx can be used as replacement of standalone symfony server started via php phing server-run

Tip

Required tools can be easily installed on Windows via choco package manager

Tip

Windows installation can be skipped in favor of Windows Subsystem for Linux (WSL) where the tools will be installed like on Linux / MacOS / WSL so all the tools and services can be up-to-date.